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AccountServer database backup fails due to timeout

Article ID: 151
Last updated: 08 Jun, 2012

Symptom

The AccountServer database backup fails with the following error, as seen in the ASLog:

Warn: ASManager: Could not backup StoragePlatform database: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding

Cause

This typically occurs on a AccountServer with a very large database. The backup of the large database takes longer than 60 seconds resulting in the connection between the AS and SQL timing out.

Solution

  1. Reduce the history of the TracePerformance table (this will not affect the SP)

    1. In Microsoft SQL Server Management Studio, edit the the Stored Procedure called TrimData.
      In Object Explorer select, <SQLServer>\Databases\StoragePlatform\Programmability\Stored Procedures, then right-click on dbo.TrimData and select Modify.
    2. Change:
      Delete TracePerformance where LogDateTime < @date
      to
      Delete TracePerformance where LogDateTime < getdate() - 1

      This will ensure performance data older than 1 day is deleted.
       
    3. Select (highlight) this modified line and select Execute on the toolbar (or press F5)

  2. Compact the database

    1. Select New Query from the toolbar
    2. Copy and paste the following into the new query:
      DBCC SHRINKDATABASE(N'StoragePlatform' )
    3. Select Execute (or F5)
Article ID: 151
Last updated: 08 Jun, 2012
Revision: 1
Views: 2762
Comments: 0
Posted: 04 Apr, 2012 by Van Rensburg J.
Updated: 08 Jun, 2012 by Marais D.
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Article 141 - Java error causing the Backup Client service to stop     Article 164 - V6.2.3 Hotfix: New VSS plug-in to backup MSDE writer