Attix5 Pro FAQ
Search:     Advanced search

Upgrading/installing your SP to V8 R6

Article ID: 343
Last updated: 25 Feb, 2016

The following restrictions have been introduced in V8 R6 and will prevent you from installing or upgrading your Storage Platform (i.e. AccountServers, StorageServers and MirrorServers) to V8 R6:

  1. At least one of your servers still use .NET 4.0
  2. At least one of your servers run on Windows Server 2003 or Window Server 2008
  3. You haven't upgraded all servers to at least V8 R4

The above restrictions will be displayed during the installation process.

Here's how to proceed when encountering the errors:

  1. Make sure all servers have .NET 4.5 installed
  2. All servers must be on Windows 2008 R2 or later
  3. All servers must be running Attix5 Pro V8 R4 or R5

See below for possible scenarios you could encounter.

a) .NET 4.0 is no longer supported

From V8 Release 6 the Storage Platform will no longer be able to run on Microsoft .NET 4.0 but will require .NET 4.5.

Here are some example scenarios of what you can expect during the process of installing or upgrading the Storage Platform:

Server Will the installation/
upgrade continue?
How do I fix this?
AS SS 1 SS 2
  1  .NET 4.5 .NET 4.5 .NET 4.5 Yes n/a
  2 .NET 4.5 .NET 4.0 .NET 4.5 No Upgrade all servers to .NET 4.5
  3 .NET 4.0 .NET 4.5 .NET 4.5 No Upgrade all servers to .NET 4.5

b) Windows 2003 is no longer supported

V8 Release 6 of the Storage Platform cannot be installed on Windows 2003 or Windows 2008 (32-bit). At least Windows 2008 R2 is required.

Here are some example scenarios of what you can expect during the process of installing or upgrading the Storage Platform:

Server Will the installation/
upgrade continue?
How do I fix this?
AS SS 1 SS 2
  1  Win 2008 R2 Win 2008 R2 Win 2008 R2 Yes

n/a

  2 Win 2008 R2 Win 2008 Win 2012 R2 No The installation is only allowed
on Windows 2008 R2 and later.
  3 Win 2008 R2 Win 2003 Win 2008 R2 No The installation is only allowed
on Windows 2008 R2 and later.
  4 Win 2003 Win 2008 R2 Win 2008 R2 No The installation is only allowed
on Windows 2008 R2 and later.

Article ID: 343
Last updated: 25 Feb, 2016
Revision: 11
Views: 567
Comments: 0
Posted: 05 Feb, 2016 by Du Plessis S.
Updated: 25 Feb, 2016 by Van Rensburg J.
This article was:  
Prev   Next
Article 344 - How to use OData endpoints to query the Storage Platform     Article 345 - How to add the Attix5 public key to your trusted store