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Manual Account Server DB backup shows successful in the SP Console but failed in the AS log (V6)

Article ID: 83
Last updated: 08 Oct, 2012

Symptom

When a Account Server DB Backup is initiated from the SP Console, the Console GUI states that the backup is successful, yet the Account Server logs state it failed (see below)

SP Console:


AS Log:
11:34:53 Info: [RPC from admin@10.10.10.10"] service.BackupDatabase
11:34:53 Warn: Could not backup StoragePlatform database: Cannot open backup device 'C:\ProgramData\Attix5 Pro\AS_Service\ServerBackups\Backupserver.bak'. Operating system error 5(error not found), BACKUP DATABASE is terminating abnormally.

Cause

This occurs when the MS SQL service logon is set to a user, eg NETWORK_SERVICE, and this user does not have sufficient rights to access the backup folder. The DB backup is therefor unable to write the backup file to this folder resulting in a failed backup.

Solutions

  • Change the MS SQL service logon to LocalSystem (default value);
  • Change the backup folder pemissions - allow the current MS SQL service logon access to this folder.
Article ID: 83
Last updated: 08 Oct, 2012
Revision: 2
Views: 3001
Comments: 0
Posted: 11 Jan, 2012 by Van Rensburg J.
Updated: 08 Oct, 2012 by Van Rensburg J.
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